Jump to content
TX-7365

AM 2.0 shin looking weird or is it just me.

Recommended Posts

Just finished my AM 2.0 shins & is it me or does it look like whey sent 2 right shins with the kit.

I followed the inside & out side curve, but some how dident take notice to the top edge until I was done. is it me, or are they suppose to look

like this. This is my first time with the AM 2.0 kit. Any help would be awesome.

post-20791-0-06459100-1449446703_thumb.jpg

post-20791-0-33848200-1449446746_thumb.jpg

post-20791-0-05544800-1449446974_thumb.jpg

Share this post


Link to post
Share on other sites

87aaebbe102ce8e6b50975665ff3bb82.jpg lol dude I was going to ask the same question as you see. Same problem.

 

 

RLH2515

Share this post


Link to post
Share on other sites

Interestingly enough, a few years ago, several of us AM 2.0 owners were mistakenly sent 2 of the same shin. We scratched our collective heads too trying to figure it out. Both you guys look good though. Those appear correct.

 

Sent from my SM-N910V using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...